Обсуждение личных бэкапов разных сборок

Mark21

Охотник
VIP
18 Апр 2009
560
182
43
UA
Дело в том, что я менял скин, на котором она стартует, на скин, идущий с ней в комплекте,
а не пытался ставить новый со стороны...
Ладно, начал сначала, попробую посмотреть что будет дальше...
 

kil1970

Любопытный
Пользователь
Дело в том, что я менял скин, на котором она стартует, на скин, идущий с ней в комплекте,
а не пытался ставить новый со стороны...
Ладно, начал сначала, попробую посмотреть что будет дальше...
значит к бекапу нужно еще было приложить комплект "конвертеров" и "рендеров" ибо хто его знает какой там скин и что он хочет
а креш пробовали смотреть
 

learn

Охотник
Пользователь
12 Окт 2010
201
123
43
63
Istanbul/Turkey
Я делаю это,... Переднюю панель Box на = кнопок меню печати, Настройка> Система> Сеть = ОК (коробка переднюю панель кнопки ОК), перейдите мастера сети один или два раза нажмите кнопку ОК, Ваш ящик теперь подключиться к Интернет, подключение в ДКК., сделать это все файлы Attrib =777.,Последние пут / и т.д. в;. Lircd.conf, Перезагрузка и положить список каналов, тип изменения тюнера ... ,, Его готовы
 
Симпатии: Понравилось lyn33

Mark21

Охотник
VIP
18 Апр 2009
560
182
43
UA
Во время видеозаставки при включении играет громко какая-то музыка. Как ее убрать?
 

metpas

FAQ'er
Координатор
17 Ноя 2012
3.321
3.930
1.063
49
One distant galaxy
forum.plitv.tv
Отключить средствами имиджа не получится. Можно либо удалить бутвидео целиком, либо отдельно отредактировать его (к примеру, отключить/удалить звуковую дорожку).
 

anatoliy61

Лис
Модератор
25 Авг 2010
665
782
93
Во время видеозаставки при включении играет громко какая-то музыка. Как ее убрать?
Сдела ть правки в initmodules или удалить в папке boot видеозаставку. Покажите, что в папке boot и initmodules.
 

metpas

FAQ'er
Координатор
17 Ноя 2012
3.321
3.930
1.063
49
One distant galaxy
forum.plitv.tv
Вот Вам для примера rcS:
Код:
#!/bin/sh

MODDIR=/lib/modules

echo "init frontpanel"
insmod $MODDIR/nuvoton.ko paramDebug=0
insmod $MODDIR/simu_button.ko

if [ -e /var/etc/.firstboot ]; then
  echo "INIT" >/dev/vfd
  echo "WAIT 1st start"
  rm /var/etc/.firstboot
  sleep 1
  touch /dev/.devfsd
fi

/etc/init.d/mountvirtfs start
/etc/init.d/portmap start

insmod $MODDIR/e2_proc.ko

if [ ! -e /var/etc/.firstboot ]; then

  echo "Starting DEBUG Interface"
  /etc/init.d/mountall start
  /etc/init.d/hostname start

  echo "starting telnetd"
  /usr/sbin/telnetd -l /bin/login

  echo "init stmfb"
  insmod $MODDIR/stmcore-display-sti7111.ko

  if  grep -q "config.av.videoport=Scart" /etc/enigma2/settings; then
  insmod $MODDIR/stmfb.ko display0=720x576i-32@50:15m:pal:yuv:yuv;#SCART
  else
  insmod $MODDIR/stmfb.ko display0=1280x720-32@50:15m:pal:yuv:yuv;#HDMI
  fi

  echo "LOADING MODULES"   
  echo "LOAD" > /dev/vfd

  echo "load a firmware"
  if [ -e /boot/audio_dts.elf ]; then
  /bin/ustslave /dev/st231-1 /boot/audio_dts.elf
  else
  /bin/ustslave /dev/st231-1 /boot/audio.elf
  fi
  echo "load v firmware"
  /bin/ustslave /dev/st231-0 /boot/video.elf

  echo "init embx"
  insmod $MODDIR/embxshell.ko
  insmod $MODDIR/embxmailbox.ko mailbox0=0xfe211000:136:set2 mailbox1=0xfe212000:0 ;
  insmod $MODDIR/embxshm.ko mailbox0=shm:0:7:0x60000000:0:256:256:0:512:0x40000000:0x10000000 ;
  insmod $MODDIR/mme_host.ko transport0=shm

  echo "init AVS"
  if [ -e /var/etc/sf918+ ]; then
   insmod $MODDIR/avs.ko type=avs_none
  else
   insmod $MODDIR/avs.ko type=avs_pio
  fi

  player=`cat /proc/stb/player/version`
  player=`cat /proc/stb/player/version | awk '{ print substr( $0, length($0) - 2, length($0) ) }'`

  echo "init player $player"
  insmod $MODDIR/mmelog.ko
  insmod $MODDIR/ksound.ko
  insmod $MODDIR/p2div64.ko
  insmod $MODDIR/stm_v4l2.ko
  insmod $MODDIR/pseudocard.ko

#  if [ $player -gt 131 ]; then
#   insmod $MODDIR/stmvout.ko
#   insmod $MODDIR/stmvbi.ko
#  fi

  if [ -e /var/etc/sf918c ]; then
     insmod $MODDIR/frontend_platform.ko
     insmod $MODDIR/socket.ko
     insmod $MODDIR/tda10024.ko
  else
   if [ -e $MODDIR/lnb.ko ]; then
     insmod $MODDIR/lnb.ko type=a8293
   fi
     insmod $MODDIR/stv090x.ko paramDebug=0
  fi


  if [ -e /var/etc/sf918+ ]; then
   insmod $MODDIR/hs7110.ko
  else
   insmod $MODDIR/starci.ko
  fi

  if [ $player -gt 131 ]; then
   if [ -e $MODDIR/pti_fta.ko ]; then
     insmod $MODDIR/pti_fta.ko
   else
     insmod $MODDIR/pti.ko waitMS=20 videoMem=4096
   fi
   insmod $MODDIR/stm_monitor.ko
   insmod $MODDIR/stmsysfs.ko
     insmod $MODDIR/stmdvb.ko
  else
   insmod $MODDIR/pti.ko
   insmod $MODDIR/stmdvb.ko
   insmod $MODDIR/stm_monitor.ko
  fi   
  insmod $MODDIR/player2.ko discardlateframe=0
  insmod $MODDIR/sth264pp.ko
  insmod $MODDIR/stmalloc.ko
  insmod $MODDIR/platform.ko
  insmod $MODDIR/silencegen.ko

  insmod $MODDIR/bpamem.ko
  mknod /dev/bpamem c 153 0

  /bin/eplayer3 /boot/bootvideo.mkv; showiframe -p /boot/bootlogo.mvi &

  stfbcontrol a 0

  mknod /dev/rc c 147 1
  mknod /dev/lnb c 149 0

  /bin/evremote2 10 140 &

  stfbcontrol a 255

  echo "starting vsftpd"
  /etc/init.d/vsftpd start
  /usr/sbin/inetd


  NFS=$(grep -c 'nfs' /proc/cmdline)
  if [ "$NFS" -eq "1" ]; then
  echo "Booting from nfs, don't set network"
  else
  #Network & restore backup management
  if [ -e /var/etc/1stboot ]; then
   echo "detected 1stboot - no network configured"
   BACKUP=`findfs LABEL=RECOVERY`
   if [ -n "$BACKUP" ]; then
     mount $BACKUP /hdd
     if [ -e /hdd/backup/autorestore.sh ]; then
       echo "BRES" > /dev/vfd
       echo "Autorestore"
       /hdd/backup/autorestore.sh
     fi
     umount /hdd
   fi  
  else
  if [ -e /etc/network/interfaces ]; then
  . /var/config/wlan.conf
  if [ $wlan == off ]; then
  /etc/init.d/networking start &
  else
  insmod /lib/modules/$wlan''.ko
  echo "$wlan driver loaded"
  /etc/init.d/networking restart &
  fi
  fi
  fi
  fi

  #init rc.modules
  /var/config/rc.modules &

  #init rc.local
  /var/config/rc.local &

  echo "run" > /dev/vfd
  echo "LOADING E2"
   

  until false
  do
  echo "starting e2->"
  python /usr/lib/enigma2/python/Plugins/Extensions/PKT/progress 70 LED &
  /usr/local/bin/enigma2.sh
  rtv=$?
  cp /tmp/reference.dat /var/bin
  echo "e2 ended <- RTV: " $rtv
  case "$rtv" in
     0) echo "0"
      echo "E2 ERROR"
  init 6;;
     1) echo "1"
      echo "SHUTDOWN"
      init 0;;
     2) echo "2"
      echo "REBOOT"
      init 6;;
     3) echo "3"
      echo "E2 RESTART"
      echo "0" > /proc/progress
      showiframe -p /boot/restart.mvi &;;
     *) echo "*"
      echo "ERROR"
      echo "0" > /proc/progress
      showiframe -p /boot/error.mvi &;;
  esac
  done
fi

#never reached
echo "REBOOT HS7810A" > /dev/vfd
echo "REBOOT HS7810A"
reboot -f
Разумеется, в /boot лежат bootvideo.mkv и все перечисленные .mvi
 
Симпатии: Понравилось lyn33

anatoliy61

Лис
Модератор
25 Авг 2010
665
782
93
Mark21, Подправил initmoduls - Замените пр.DCC -(init 4 _замена_init 6) . В папку boot забросьте bootlogo.mvi - сбросил пока не подберете себе
 

Вложения

metpas

FAQ'er
Координатор
17 Ноя 2012
3.321
3.930
1.063
49
One distant galaxy
forum.plitv.tv
Если флуд, то не от меня. Вопрос был:
Во время видеозаставки при включении играет громко какая-то музыка. Как ее убрать?
Вы ответили, что это можно сделать средствами имиджа.
Я уточнил:
расскажите, как средствами имиджа отключить звук в бутвидео, не меняя самого видеофайла.
Вы, извините, не на тот вопрос ответили. А удалить файл, или строку из скрипта... Разницы нет особой. Вариантов только два. Либо не воспроизводить бутвидео вовсе, либо исправить файл видео. О чем, собсно, я и отписал.